Re: ANNOUNCE: xfce4-screenshooter 1.9.0 released

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ANNOUNCE: xfce4-screenshooter 1.9.0 released

Yves-Alexis Perez-2
On Sat, 2017-06-24 at 20:18 +0200, André Miranda wrote:

> Release notes for 1.9.0
> =======================
> This is a major release indicating that the gtk3 version of
> xfce4-screenshooter has become stable enough to be officially released
> and taken by all distributions.
>
>   * Enhancements:
>     - Downgrade xfce4-panel dependency to 4.12
>     - Updated translations (thanks to translators!)
>
>   * Bugs fixed:
>     - Use HTTPS for imgur (bug #13415)
Hi,

unfortunately, screenshooter depends on exo-2 0.11 which is still a
development release, so we have a plugin stable release depending on a library
development relase, which is not optimal, I guess.

Regards,
--
Yves-Alexis
_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ANNOUNCE: xfce4-screenshooter 1.9.0 released

André Miranda
Yes, there's not much I can do since it's a gtk3 component and exo-1 is gtk2 only. Note that screenshooter is not only a panel plugin, but an application by itself.
Whiskermenu is also using exo-2 since 2.0.0 and exo-2 is already shipped by Ubuntu (17.04) and Arch.

Cheers,
Andre Miranda

On Mon, Jun 26, 2017 at 5:25 AM, Yves-Alexis Perez <[hidden email]> wrote:
On Sat, 2017-06-24 at 20:18 +0200, André Miranda wrote:
> Release notes for 1.9.0
> =======================
> This is a major release indicating that the gtk3 version of
> xfce4-screenshooter has become stable enough to be officially released
> and taken by all distributions.
>
>   * Enhancements:
>     - Downgrade xfce4-panel dependency to 4.12
>     - Updated translations (thanks to translators!)
>
>   * Bugs fixed:
>     - Use HTTPS for imgur (bug #13415)

Hi,

unfortunately, screenshooter depends on exo-2 0.11 which is still a
development release, so we have a plugin stable release depending on a library
development relase, which is not optimal, I guess.

Regards,
--
Yves-Alexis


_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ANNOUNCE: xfce4-screenshooter 1.9.0 released

Ali Abdallah-3
First congrats for the good work.

On Mon, Jun 26, 2017 at 11:08:29AM -0300, André Miranda wrote:
> Yes, there's not much I can do since it's a gtk3 component and exo-1 is
> gtk2 only. Note that screenshooter is not only a panel plugin, but an
> application by itself.

If you depend on a development version of any library, then you
shouldn't in principle call your release a stable one.

> Whiskermenu is also using exo-2 since 2.0.0 and exo-2 is already shipped by
> Ubuntu (17.04) and Arch.
Great, but again, or exo-2 has to be flagged as "stable", or yet it has
to receive more tests. If Whiskermenu flags its exo-2 based releases as
stable and exo-2 itself is no considered as such, then there is
something wrong with Whiskermenu itself...

Distros are free to ship whatever softwares/libraries versions they want,
that are considered by their own developers to be "development releases".


> Cheers,
> Andre Miranda

Cheers,
Ali

>
> On Mon, Jun 26, 2017 at 5:25 AM, Yves-Alexis Perez <[hidden email]>
> wrote:
>
> > On Sat, 2017-06-24 at 20:18 +0200, André Miranda wrote:
> > > Release notes for 1.9.0
> > > =======================
> > > This is a major release indicating that the gtk3 version of
> > > xfce4-screenshooter has become stable enough to be officially released
> > > and taken by all distributions.
> > >
> > >   * Enhancements:
> > >     - Downgrade xfce4-panel dependency to 4.12
> > >     - Updated translations (thanks to translators!)
> > >
> > >   * Bugs fixed:
> > >     - Use HTTPS for imgur (bug #13415)
> >
> > Hi,
> >
> > unfortunately, screenshooter depends on exo-2 0.11 which is still a
> > development release, so we have a plugin stable release depending on a
> > library
> > development relase, which is not optimal, I guess.
> >
> > Regards,
> > --
> > Yves-Alexis

> _______________________________________________
> Xfce4-dev mailing list
> [hidden email]
> https://mail.xfce.org/mailman/listinfo/xfce4-dev

_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev
Loading...