How to panel plugin

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

How to panel plugin

Dani
Hello:

For gtk3.

https://wiki.xfce.org/dev/howto/panel_plugins
say:

Plugin Registration
To register a plugin with the plugin system there are two macros
available that should be used, instead of using the library functions
directly; one for internal plugins and one for external plugins.
XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL(construct);


but here:
http://www6.frugalware.org/mirrors/linux/vectorlinux/veclinux-7.1/usr/share/gtk-doc/html/libxfce4panel-1.0/libxfce4panel-Panel-Plugin-Register-Macros-(4.6-Style).html
say:

Warning
XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL has been deprecated since version
4.8 and should not be used in newly-written code. Deprecation is not
entirely true, but it should be made clear that it is recommended to use
XFCE_PANEL_PLUGIN_REGISTER(). See the Registering Plugins for more
information.


My question, should I use
XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL
or not?




--
Dani


_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: How to panel plugin

Matthew Brush
On 2017-05-05 10:46 AM, Dani wrote:

> Hello:
>
> For gtk3.
>
> https://wiki.xfce.org/dev/howto/panel_plugins
> say:
>
> Plugin Registration
> To register a plugin with the plugin system there are two macros
> available that should be used, instead of using the library functions
> directly; one for internal plugins and one for external plugins.
> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL(construct);
>
>
> but here:
> http://www6.frugalware.org/mirrors/linux/vectorlinux/veclinux-7.1/usr/share/gtk-doc/html/libxfce4panel-1.0/libxfce4panel-Panel-Plugin-Register-Macros-(4.6-Style).html
>
> say:
>
> Warning
> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL has been deprecated since version
> 4.8 and should not be used in newly-written code. Deprecation is not
> entirely true, but it should be made clear that it is recommended to use
> XFCE_PANEL_PLUGIN_REGISTER(). See the Registering Plugins for more
> information.
>
>
> My question, should I use
> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL
> or not?
>

You should build and use the documentation from the version of
libxfce4panel you're porting with, presumably master branch from Git. It
should say what's deprecated or not, and if it says that macro is
deprecated, then don't use it.

Regards,
Matthew Brush

_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: How to panel plugin

Dani

Dani

On 06/05/17 02:18, Matthew Brush wrote:

> On 2017-05-05 10:46 AM, Dani wrote:
>> Hello:
>>
>> For gtk3.
>>
>> https://wiki.xfce.org/dev/howto/panel_plugins
>> say:
>>
>> Plugin Registration
>> To register a plugin with the plugin system there are two macros
>> available that should be used, instead of using the library functions
>> directly; one for internal plugins and one for external plugins.
>> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL(construct);
>>
>>
>> but here:
>> http://www6.frugalware.org/mirrors/linux/vectorlinux/veclinux-7.1/usr/share/gtk-doc/html/libxfce4panel-1.0/libxfce4panel-Panel-Plugin-Register-Macros-(4.6-Style).html 
>>
>>
>> say:
>>
>> Warning
>> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL has been deprecated since version
>> 4.8 and should not be used in newly-written code. Deprecation is not
>> entirely true, but it should be made clear that it is recommended to use
>> XFCE_PANEL_PLUGIN_REGISTER(). See the Registering Plugins for more
>> information.
>>
>>
>> My question, should I use
>> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL
>> or not?
>>
>
> You should build and use the documentation from the version of
> libxfce4panel you're porting with, presumably master branch from Git.
> It should say what's deprecated or not, and if it says that macro is
> deprecated, then don't use it.

Where is the documentation (reference manual) and source code of
libxfce4panel-2.0?
Not finding success.


_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: How to panel plugin

Matthew Brush
On 2017-05-06 04:31 AM, Dani wrote:

>
> Dani
>
> On 06/05/17 02:18, Matthew Brush wrote:
>> On 2017-05-05 10:46 AM, Dani wrote:
>>> Hello:
>>>
>>> For gtk3.
>>>
>>> https://wiki.xfce.org/dev/howto/panel_plugins
>>> say:
>>>
>>> Plugin Registration
>>> To register a plugin with the plugin system there are two macros
>>> available that should be used, instead of using the library functions
>>> directly; one for internal plugins and one for external plugins.
>>> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL(construct);
>>>
>>>
>>> but here:
>>> http://www6.frugalware.org/mirrors/linux/vectorlinux/veclinux-7.1/usr/share/gtk-doc/html/libxfce4panel-1.0/libxfce4panel-Panel-Plugin-Register-Macros-(4.6-Style).html
>>>
>>>
>>> say:
>>>
>>> Warning
>>> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL has been deprecated since version
>>> 4.8 and should not be used in newly-written code. Deprecation is not
>>> entirely true, but it should be made clear that it is recommended to use
>>> XFCE_PANEL_PLUGIN_REGISTER(). See the Registering Plugins for more
>>> information.
>>>
>>>
>>> My question, should I use
>>> XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL
>>> or not?
>>>
>>
>> You should build and use the documentation from the version of
>> libxfce4panel you're porting with, presumably master branch from Git.
>> It should say what's deprecated or not, and if it says that macro is
>> deprecated, then don't use it.
>
> Where is the documentation (reference manual) and source code of
> libxfce4panel-2.0?
> Not finding success.
>

https://git.xfce.org/xfce/xfce4-panel/

_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: How to panel plugin

André Miranda
In reply to this post by Dani
Dani,
I tried to review your repository, but one big commit is not easy on my strained eyes.
I noticed some commented code and some files renamed/deleted/recreated without a clear reason, please don't push these things, they only confuse.
Currently it's not possible to build due an error on Makefile about an image, take a look at xfce4-dict where I made some changes related to the panel plugin icon. It came to my attention that you replaced the icon by one that seems to be from onlinewebfonts.com and according to what's present in the SVG it's under this license: https://creativecommons.org/ns
I recommend not to change the current icon unless you have a good reason to, otherwise an attribution will be necessary.

Regarding the documentation, unfortunately it's far from updated, the page you mentioned hasn't been touch since 2010 (I touch it recently, but only to add information, I didn't update it). As Matthew hinted, the better documentation we have is the source code itself.

Cheers,
Andre Miranda

On 05/06/2017 08:31 AM, Dani wrote:

Dani

On 06/05/17 02:18, Matthew Brush wrote:
On 2017-05-05 10:46 AM, Dani wrote:
Hello:

For gtk3.

https://wiki.xfce.org/dev/howto/panel_plugins
say:

Plugin Registration
To register a plugin with the plugin system there are two macros
available that should be used, instead of using the library functions
directly; one for internal plugins and one for external plugins.
XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL(construct);


but here:
http://www6.frugalware.org/mirrors/linux/vectorlinux/veclinux-7.1/usr/share/gtk-doc/html/libxfce4panel-1.0/libxfce4panel-Panel-Plugin-Register-Macros-(4.6-Style).html

say:

Warning
XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL has been deprecated since version
4.8 and should not be used in newly-written code. Deprecation is not
entirely true, but it should be made clear that it is recommended to use
XFCE_PANEL_PLUGIN_REGISTER(). See the Registering Plugins for more
information.


My question, should I use
XFCE_PANEL_PLUGIN_REGISTER_EXTERNAL
or not?


You should build and use the documentation from the version of libxfce4panel you're porting with, presumably master branch from Git. It should say what's deprecated or not, and if it says that macro is deprecated, then don't use it.

Where is the documentation (reference manual) and source code of libxfce4panel-2.0?
Not finding success.


_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev


_______________________________________________
Xfce4-dev mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce4-dev
Loading...