[Bug 13756] New: SIGSEGV when thumbnailer is under heavy load after opening many tabs

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 13756] New: SIGSEGV when thumbnailer is under heavy load after opening many tabs

bugzilla-daemon
https://bugzilla.xfce.org/show_bug.cgi?id=13756

            Bug ID: 13756
           Summary: SIGSEGV when thumbnailer is under heavy load after
                    opening many tabs
    Classification: Xfce Core
           Product: Thunar
           Version: 1.6.11
          Hardware: PC (x86_64)
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: Medium
         Component: General
          Assignee: [hidden email]
          Reporter: [hidden email]
        QA Contact: [hidden email]
                CC: [hidden email], [hidden email]
  Target Milestone: Unspecified

Created attachment 7249
  --> https://bugzilla.xfce.org/attachment.cgi?id=7249&action=edit
fix (see bug desc)

Analyzing the coredump I assume this happened due to invalid access to
job->thumbnailer. I guess the _thunar_return_if_fail() checks a few lines down
should happen earlier.

Unfortunately, I don't have a reliable way of reproducing the issue in order to
check whether the attached patch is a valid fix.

Cheers
Daniel

--
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
Xfce-bugs mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce-bugs
Loading...