[Bug 13326] New: libxfce4ui has become dependent on exo which is dependent on libxfce4ui

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 13326] New: libxfce4ui has become dependent on exo which is dependent on libxfce4ui

bugzilla-daemon
https://bugzilla.xfce.org/show_bug.cgi?id=13326

            Bug ID: 13326
           Summary: libxfce4ui has become dependent on exo  which is
                    dependent on libxfce4ui
    Classification: Xfce
           Product: Libxfce4ui
           Version: git
          Hardware: Other
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: Medium
         Component: General
          Assignee: [hidden email]
          Reporter: [hidden email]
                CC: [hidden email], [hidden email]
  Target Milestone: 4.14

recently trying to build discovered a dependancy of libxfce4ui git version on
exo git which is also dependent on libxfce4ui git  I had to build
libxfce4ui-4.12 then exo git version then libxfce4ui git then exo git again ..

exo-common is called by libxfce4ui git during early build process ..

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Xfce-bugs mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce-bugs
Reply | Threaded
Open this post in threaded view
|

[Bug 13326] libxfce4ui has become dependent on exo which is dependent on libxfce4ui

bugzilla-daemon
https://bugzilla.xfce.org/show_bug.cgi?id=13326

Skunnyk <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]

--- Comment #1 from Skunnyk <[hidden email]> ---
Introduced by
https://git.xfce.org/xfce/libxfce4ui/commit/?id=82c11fd69c84f082d7a309b2844b6814f35aa73c
? Which add a exo-csource exec in libxfce4ui when enable gtk3 ?

Maybe replace it by xdt-csource ?

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Xfce-bugs mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce-bugs
Reply | Threaded
Open this post in threaded view
|

[Bug 13326] libxfce4ui has become dependent on exo which is dependent on libxfce4ui

bugzilla-daemon
In reply to this post by bugzilla-daemon
https://bugzilla.xfce.org/show_bug.cgi?id=13326

--- Comment #2 from Skunnyk <[hidden email]> ---
xdt-csource is only mandatory when building from git, so it's not a solution.

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Xfce-bugs mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce-bugs
Reply | Threaded
Open this post in threaded view
|

[Bug 13326] libxfce4ui has become dependent on exo which is dependent on libxfce4ui

bugzilla-daemon
In reply to this post by bugzilla-daemon
https://bugzilla.xfce.org/show_bug.cgi?id=13326

Eric Koegel <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |[hidden email]
             Status|NEW                         |ASSIGNED

--- Comment #3 from Eric Koegel <[hidden email]> ---
This should be fixed in master now with the following commit:

commit 1a2edb377bc90f2abbf79f5a64b5e9fddd90e72e
Author: Eric Koegel <[hidden email]>
Date:   Thu May 11 14:01:59 2017 +0300

    Remove exo dependancy (Bug #13326)

    exo-csource was accidently added in the Gtk3 port. Switch to
    compiling it as a GResource and loading that via GtkBuilder.
https://git.xfce.org/xfce/libxfce4ui/commit/?id=1a2edb377bc90f2abbf79f5a64b5e9fddd90e72e

I'm not sure if there needs to be a configure check for finding the
glib-compile-resources binary so I'll leave this open for a bit.

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Xfce-bugs mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce-bugs
Reply | Threaded
Open this post in threaded view
|

[Bug 13326] libxfce4ui has become dependent on exo which is dependent on libxfce4ui

bugzilla-daemon
In reply to this post by bugzilla-daemon
https://bugzilla.xfce.org/show_bug.cgi?id=13326

--- Comment #4 from Git Bot <[hidden email]> ---
Eric Koegel referenced this bugreport in commit
89fa6ec8756e3bb1af923d457fe50511a6c14fa0

Let autotools find and invoke glib-compile-resources (Bug #13326)

https://git.xfce.org/xfce/libxfce4ui/commit?id=89fa6ec8756e3bb1af923d457fe50511a6c14fa0

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Xfce-bugs mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce-bugs
Reply | Threaded
Open this post in threaded view
|

[Bug 13326] libxfce4ui has become dependent on exo which is dependent on libxfce4ui

bugzilla-daemon
In reply to this post by bugzilla-daemon
https://bugzilla.xfce.org/show_bug.cgi?id=13326

Eric Koegel <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |RESOLVED
         Resolution|---                         |FIXED

--- Comment #5 from Eric Koegel <[hidden email]> ---
Marking closed.

--
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Xfce-bugs mailing list
[hidden email]
https://mail.xfce.org/mailman/listinfo/xfce-bugs